Jump to content
Sign in to follow this  
xavo

ffmpeg a stream - problem

Recommended Posts

Witam,

 

Używam softu OpenATV 6.1 na dekoderze Red Eagle Twinbox LCD.

 

problem 1 - Przy próbie odtwarzania strumienia w IPTV Player otrzymuję komunikat o braku ExtEplayer3.

Odnalazłem serię instrukcji pozwalający na uzupełnienie brakującego softu za pomocą telnetu. Problem zniknął - strumień jest odtwarzany prawidłowo.

problem 2 - mam przekierowanie na routerze dzięki któremu mogę oglądać czasem coś będąc w pracy (np. mecz czy skoki :)).

Tutaj przechodzę do meritum. Po zainstalowaniu ExtEplayer oraz ffmpeg obraz zaczął ciąć bardzo mocno uniemożliwiając dalsze oglądanie.

 

Czy ktoś mógłby mi podpowiedzieć gdzie znaleźć różne wersje ffmpeg? To chyba kodeki są przyczyną tego stanu rzeczy.

Jak deinstalować/instalować kodeki? Poszukam takiego zestawu, który obsłuży oba strumienie i pozwoli na prawidłowy odbiór.

 

z góry dziękuję za pomoc

Share this post


Link to post
Share on other sites

@xavo

 

No nie. Masz błędne informacje. ffmpeg i jego kodeki nie są wykorzystywane ani w IPTVPlayerze ani tym bardziej do strewam'owania.

ffmpeg i jego biblioteki są używane tylko do demultipleksacji i to tylko mediów. Za dekodowanie odpowiedzialne są dedykowane układy, procesory sygnałowe.

 

Jak stream'ujesz sobie z dekodera to żadne biblioteki z ffmpeg'a nie są używane.

A jak masz dostęp do stremowania nie zabezpieczony to raczej sobie sprawdź, czy ktoś na lewo Ci się nie podłącza do dekodera, przez co Twoje łącze nie wyrabia i dlatego tnie.

Share this post


Link to post
Share on other sites

Ok.

W takim razie co może być przyczyną cięcia obrazu? Wcześniej stream szedł gładko, teraz nagle tnie jak diabli.

W tej chwili zacząłem bawić się VLC na swoim PC. Jest tam możliwość streamowania oglądanego kanału. Niestety pomimo przekierowania portów w routerze nie mogę się zdalnie podpiąć do streamu...

Walka trwa :)

Edited by xavo

Share this post


Link to post
Share on other sites

@xavo

 

Możliwą przyczynę Ci już napisałem. A co do ffmpeg'a i jego libów to możesz je zupełnie usunąć z twojego image i nie wpłynie to na stream'owanie.

Sprawdź sam.

Share this post


Link to post
Share on other sites

Witam. Ja jako ciekawostkę dodam,że Vti team coś skopał w najnowszym image bo jak zainstaluje exteplayer3 to stream(w liście kanałów) z 3 moich kamer hikivision powoduje reboot a z czwartej odpala normalnie. Jak usunę liby to wszystko działa normalnie. Natomiast stream ze wszystkich kamer po wpisaniu do Iptv Payer działa bardzo dobrze. Wygląda na to, że się gryzą.

Dzięki @samsamsam za super robotę którą wykonujesz. Pozdrawiam

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.