Jump to content
Na forum sat-4-all.com obowiązuje bezwzględny zakaz oferowania sharingu oraz umieszczania linków do treści łamiących prawa autorskie.
vodolot

Skrypty dla oscama na vps-ie.

Recommended Posts

Witam.

Panowie mam prośbę do znających się na rzeczy.

Chciałbym pobawić się oscamem na vps-ie z debianem.

Prosiłbym o podpowiedź jak powinien wyglądać skrypt startujący dla oscama i watchdog sprawdzający co np. 5 minut czy oscam działa.

Z góry dzięki za pomoc.

Pozdro.

Share this post


Link to post
Share on other sites

Zaden skrypt do odpalania nie jest potrzebny. Wystarczy dodac komende uruchamiajaca oscama do /etc/init.d/rc.local

 

np.

 

/usr/bin/oscam -b

 

i to wszystko. Po kazdym restarcie oscam sie odpali. Zaden watchdog nie jest potrzebny bo oscam jest stabilny jak skala i dziala bez restartu LATAMI, no chyba ze dostawca vps-a robi restart po upgrade systemu co czasami sie zdarza. Oczywiscie mozna sobie napisac skrypt sprawdzajacy log i dodac go do crond-a. Kiedys sie tym bawilem jak chcialem by system wylapywal mi pewne nieprawidlowosci w log-u, np. timeouty i podejmowal w zwiazku z tym jakies dzialania (np. zalaczal inny reader ktory na stale byl wylaczony). Ale to jest zabawa tak naprawde zupelnie zbyteczna i jak wszystko jest dobrze przemyslane i rozplanowane to zadnego watchdoga nie trzeba.

Share this post


Link to post
Share on other sites

Dzięki za podpowiedzi.

Proszę o cierpliwość , to co dla Was jest dłubaniem w nosie dla mnie jest kurde chińszczyzną.

Jedyne co potrafię - to odpalić  oscama przez terminal tą komendą:

/usr/local/config/oscam_2/bin/oscam_2 -b -c /usr/local/config/oscam_2/etc -t /tmp/.oscam_2

binarka i configi są w tych katalogach j.w

Gdy dopiszę komendę do rc.local :

. /usr/local/config/oscam_2/bin/oscam_2 -b

dostaje komunikat :

Polecenie '"./rc.local"'
zawiodło zwracając kod wyniku 3 oraz komunikat błędu
./rc.local: line 16: .: /usr/local/config/oscam_2/bin/oscam_2: cannot execute binary file
Usage: ./rc.local start|stop.

 

 A tak wygląda mój cały rc.local:

 

#! /bin/sh
### BEGIN INIT INFO
# Provides:          rc.local
# Required-Start:    $remote_fs $syslog $all
# Required-Stop:
# Default-Start:     2 3 4 5
# Default-Stop:
# Short-Description: Run /etc/rc.local if it exist
### END INIT INFO


PATH=/sbin:/usr/sbin:/bin:/usr/bin

. /lib/init/vars.sh
. /lib/lsb/init-functions
. /usr/local/config/oscam_2/bin/oscam_2 -b

do_start() {
    if [ -x /etc/rc.local ]; then
            [ "$VERBOSE" != no ] && log_begin_msg "Running local boot scripts (/etc/rc.local)"
        /etc/rc.local
        ES=$?
        [ "$VERBOSE" != no ] && log_end_msg $ES
        return $ES
    fi
}

case "$1" in
    start)
    do_start
        ;;
    restart|reload|force-reload)
        echo "Error: argument '$1' not supported" >&2
        exit 3
        ;;
    stop)
        ;;
    *)
        echo "Usage: $0 start|stop" >&2
        exit 3
        ;;
esac

 

 

Share this post


Link to post
Share on other sites

@kalikamp i jesteśmy w domu :-).

Poprzerzucałem wszystko do domyślnych lokalizacji , oscam też jest teraz nie oscam_2 i chula.

Dziękuję za łopatologię , cierpliwość i pomoc.

Pozdro.

Share this post


Link to post
Share on other sites

 

W dniu 8.06.2019 o 15:44, kalikamp napisał:

Przeciez rc.local nie jest do odpalania. Ten plik jest brany pod uwage przy starcie systemu i z niego odpalane sa inne skrypty/binaria ktore tam dopiszesz na koncu. Jak chcesz recznie odpalac i ubijac oscama to poslugujesz sie standardowymi poleceniami czyli w twoim przypadku:

 

killall oscam_2

(ta komenda ubijasz oscam_2)

 

Jesli wszystkie binaria i skrypty wrzucasz do /usr/bin (a tak powinienes robic) to nie musisz podawac sciezki by odpalic taki plik, czyli chcac go odpalic z konsoli wpisujesz po prostu:

 

oscam_2 -b

 

"-b" w tym wypadku oznacza background czyli oscam_2 odpali ci sie w tle bez blokowania konsoli. Oczywiscie odpalajac oscam_2 bez podania sciezki do konfigow oscam szuka ich w standardowej lokalizacji czyli /usr/local/etc (no chyba ze przy kompilowaniu podasz wlasna sciezke dla tej binarki. Ja np. zawsze tak robie, by nie bawic sie pozniej w podawanie sciezek przy manualnym odpalaniu). Jesli konfigi sa w niestandardowej lokalizacji to musisz odpalic oscama z parametrem "-c" po ktorym podajesz sciezke do konfigow. Przyklad przy zalozeniu ze oscam_2 jest w /usr/bin/ a konfigi w /usr/local/config/oscam_2/ :

 

oscam_2 -b -c /usr/local/config/oscam_2/

 

 

 

@kalikamp  pomocy !  Zaktualizowałem vpsa - jest teraz na nim Ubuntu 16.04 64bit  i nie odpala mi się automatycznie oscam po reboocie vpsa. Plik rc.local zrobiłem jak poprzednio gdy działał .

Czasem też oscam sam się wyłącza, co może być przyczyną?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.